Unverified Commit d6410f96 authored by Clarakosi's avatar Clarakosi Committed by GitHub
Browse files

Revert "Rollback some dependencies to still support node 6"

parent 6ff2a129
......@@ -9,7 +9,7 @@ jobs:
strategy:
matrix:
node-version: [6.x, 10.x, 12.x]
node-version: [10.x, 12.x]
steps:
- uses: actions/checkout@v2
......
{
"name": "service-runner",
"version": "2.7.6",
"version": "2.7.4",
"description": "Generic nodejs service supervisor / cluster runner",
"main": "service-runner.js",
"bin": {
......@@ -43,7 +43,7 @@
"js-yaml": "^3.13.1",
"limitation": "^0.2.1",
"semver": "^7.1.2",
"yargs": "^14.2.2"
"yargs": "^15.1.0"
},
"optionalDependencies": {
"gc-stats": "^1.4.0",
......@@ -52,9 +52,11 @@
"devDependencies": {
"@ojolabs/bunyan-prettystream": "^0.1.6",
"coveralls": "^3.0.9",
"eslint": "^5.16.0",
"eslint-config-wikimedia": "^0.14.3",
"mocha": "^6.2.2",
"eslint": "^6.8.0",
"eslint-config-wikimedia": "^0.15.0",
"eslint-plugin-json": "^2.0.1",
"eslint-plugin-jsdoc": "^21.0.0",
"mocha": "^7.0.1",
"mocha-lcov-reporter": "^1.3.0",
"nyc": "^15.0.0"
}
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment