npm-outdated-nodejs-10-ci.yml 658 Bytes
Newer Older
Mstyles's avatar
Mstyles committed
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
npm-outdated_dependency_check:

    image: docker-registry.wikimedia.org/nodejs10-devel:0.0.4-20211031
    stage: test
    allow_failure: false # failed security job fails pipeline by default

    before_script:
        - apt-get update -yqq
        - npm install -g check-outdated
        - npm install

    # create a new package lock file, run auditjs
    script:
        - check-outdated --ignore-pre-releases --ignore-dev-dependencies

    # only run on changes to package and package.lock .json
    only:
        changes:
            - package.json
            - package-lock.json
            - "**/*package.json"
            - "**/*package-lock.json"