Commit f596c54d authored by Addshore's avatar Addshore 🏄
Browse files

|| true for yarn install

parent ba5ac493
Pipeline #439 failed with stages
in 8 seconds
......@@ -7,13 +7,11 @@ stages:
- test
- build
# The `--ignore-engines` is currently needed, else we get a `error rollup-plugin-dts@3.0.2: The engine "node" is incompatible with this module. Expected version ">=v12.22.1". Got "12.21.0"`
test:
stage: test
before_script:
- $(mkdir ./yarn && cd ./yarn && npm install yarn)
- ./yarn/node_modules/.bin/yarn install --ignore-engines
- $(mkdir ./yarn && cd ./yarn && npm install yarn) || true
- ./yarn/node_modules/.bin/yarn install
script:
- ./yarn/node_modules/.bin/yarn prettier:check
- ./yarn/node_modules/.bin/yarn lint:all
......@@ -22,8 +20,8 @@ test:
build:
stage: build
before_script:
- $(mkdir ./yarn && cd ./yarn && npm install yarn)
- ./yarn/node_modules/.bin/yarn install --frozen-lockfile --ignore-engines
- $(mkdir ./yarn && cd ./yarn && npm install yarn) || true
- ./yarn/node_modules/.bin/yarn install --frozen-lockfile
script:
- ./yarn/node_modules/.bin/yarn tsc
- ./yarn/node_modules/.bin/yarn build
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment